|RANDOM(4)||Device Drivers Manual||RANDOM(4)|
— random data source devices
random devices produce high
quality random output data. Entropy data is collected from system activity
(like disk, network, and clock device interrupts and such), and then run
through various hash or message digest functions to generate the output. All
the random devices are expected to provide high quality pseudo-random output
The arc4random(3) function in userland libraries seeds itself from this device (or with the sysctl(3) interface), providing a second level of ARC4 hashed data without the need to access these devices every time.
random device first appeared in the
Linux operating system. This is a cloned interface.
ARC4 routines added by David Mazieres.
No randomness testing suite provided.
|January 11, 2011||OpenBSD-5.1|