|PGT(4)||Device Drivers Manual||PGT(4)|
pgt* at cardbus?
pgt* at pci?
pgtdriver provides support for Conexant/Intersil GT-series devices which can support the Full-Mac firmwares, using the ISL3877, ISL3880, and ISL3890 chips. The
pgtdriver will not (yet) work on similar devices using the ISL3886 or similar chips which use the Soft-Mac firmwares.
These are the modes the
pgt driver can
pgt driver can be configured to use
hardware Wired Equivalent Privacy (WEP). It is strongly recommended that WEP
not be used as the sole mechanism to secure wireless communication, due to
serious weaknesses in it.
These firmware files are not free because Conexant refuses to grant distribution rights. In fact they have rebuffed thousands of attempts to start a dialogue on this issue. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to download these files on their own.
A prepackaged version of the firmware, designed to be used with pkg_add(1), can be found at:
|D-Link DWL-g650 A1||ISL3890||PCI|
|I-O Data WN-G54/CB||ISL3890||PCI|
|I4 Z-Com XG-600||ISL3890||PCI|
|I4 Z-Com XG-900||ISL3890||PCI|
|Intersil PRISM Indigo||ISL3877||PCI|
|Intersil PRISM Duette||ISL3890||PCI|
|NETGEAR WG511 (Taiwanese, not Chinese)||ISL3890||CardBus|
|SMC EZ Connect g 2.4GHz SMC2802W||ISL3890||PCI|
|SMC EZ Connect g 2.4GHz SMC2835W-v2||ISL3890||CardBus|
|ZyXEL ZyAIR G-100||ISL3890||CardBus|
dhcp NONE NONE NONE nwkey 0x1deadbeef1 chan 11
The following hostname.if(5) example creates a host-based access point on boot:
inet 192.168.1.1 255.255.255.0 NONE media autoselect \ mediaopt hostap nwid my_net chan 11
Configure pgt0 for WEP, using hex key “0x1deadbeef1”:
# ifconfig pgt0 nwkey 0x1deadbeef1
Return pgt0 to its default settings:
# ifconfig pgt0 -bssid -chan media autoselect \ nwid "" -nwkey
Join an existing BSS network, “my_net”:
# ifconfig pgt0 192.168.1.1 netmask 0xffffff00 nwid my_net
pgtdriver first appeared in OpenBSD 4.0.
pgtdriver was originally written for FreeBSD by Brian Fundakowski, and then rewritten for OpenBSD by Marcus Glocker and Claudio Jeker.
|September 3, 2011||OpenBSD-5.1|