|MALO(4)||Device Drivers Manual||MALO(4)|
malo* at cardbus?
malo* at pci?
malo* at pcmcia?
malodriver provides support for Marvell Libertas 88W8335/88W8310/88W8385 based PCI/CardBus/PCMCIA network adapters. The second generation 88W8335/88W8310 chipsets support 802.11b/g.
These are the modes the
malo driver can
malo driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA-PSK and
WPA2-PSK). WPA is the de facto encryption standard for wireless networks. It
is strongly recommended that WEP not be used as the sole mechanism to secure
wireless communication, due to serious weaknesses in it. The
malo driver relies on the software 802.11 stack for
both encryption and decryption of data frames.
These firmware files are not free because Marvell refuses to grant distribution rights. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to download these files on their own.
A prepackaged version of the firmware, designed to be used with pkg_add(1), can be found at:
|I-O DATA WN-G54/CF||88W8385||PCMCIA||b/g|
dhcp NONE NONE NONE nwkey 0x1deadbeef1 chan 11
Configure malo0 to join network “my_net” using WPA with passphrase “my_passphrase”:
# ifconfig malo0 nwid my_net wpakey my_passphrase
Join an existing BSS network, “my_net”:
# ifconfig malo0 192.168.1.1 netmask 0xffffff00 nwid my_net
malodriver first appeared in OpenBSD 4.1.
malodriver was written by Claudio Jeker and Marcus Glocker.
|January 21, 2012||OpenBSD-5.1|