|NETSTART(8)||System Manager's Manual||NETSTART(8)|
] interface ...
netstartis the command script that is invoked by rc(8) during an automatic reboot and after single-user mode is exited; it performs network initialization. The
netstartscript can also be used to start newly created bridges or interfaces, or reset existing interfaces to their default state. The behaviour of this script is (or can be) controlled to some extent by variables defined in rc.conf(8), which specifies which daemons and services are to be run. During the system boot,
netstartperforms the following operations, in the sequence given:
-noption reports the steps that would be taken, without actually configuring the interface. multicast(4), defaultdomain(5), hostname.if(5), myname(5), ifconfig(8), rc(8), rc.conf(8)
netstartcommand first appeared in 4.0BSD.
|March 7, 2018||OpenBSD-current|