|AGGR(4)||Device Drivers Manual||AGGR(4)|
aggr — IEEE
802.1AX Link Aggregation network interface
aggr driver implements IEEE 802.1AX
(formerly 802.3ad) Link Aggregation for combining one or more Ethernet
interfaces into a single logical interface. The Link Aggregation Control
Protocol (LACP) is used to negotiate the aggregation of member interfaces
with a partner device.
aggr interfaces must be configured to use
one or more Ethernet interfaces as ports, and communicate with a partner
device over those ports using LACP. Member interfaces that negotiate with a
partner device are aggregated into a single logical link. Packets
transmitted through an
aggr interface select an
aggregated interface for transmission. Packets received by an aggregated
device appear to be received by the
it is a member of.
aggr interfaces can be created at runtime
create command or by setting up a
hostname.if(5) configuration file
for netstart(8). The interface itself
can be configured with ifconfig(8); see
its manual page for more information.
A random MAC address is generated when an
aggr interface is created. A specific MAC address
can be assigned using the ifconfig(8)
Other forms of aggregation of Ethernet interfaces are available using the trunk(4) driver.
aggr virtual interface on top of
two physical interfaces:
# ifconfig aggr0 create # ifconfig aggr0 trunkport em0 # ifconfig aggr0 trunkport em1 # ifconfig aggr0 10.1.1.100/24 # ifconfig aggr0 up
IEEE 802.1AX Link Aggregation.
aggr driver first appeared in
|September 2, 2020||OpenBSD-current|