|MOUNT_VND(8)||System Manager's Manual||MOUNT_VND(8)|
mount_vnd — mount
For fstab(5) lines with type “ffs”, the “noauto” option must be set to prevent a mount(8) of the FFS partitions before the necessary vnd devices are configured. Also, the “fs_passno” field has to be set to 0 to prevent fsck(8) from checking the file system for the same reasons.
mount_vnd is invoked by
mount(8) when using the following
mount[options] -t vnd image vnd_dev
The options are as follows:
-Soption. The passphrase and salt are combined according to PKCS #5 PBKDF2 for the specified number of rounds to generate the actual key used. rounds is a number between 1000 and
INT_MAX. DO NOT LOSE THE SALT FILE.
-oflag followed by a comma separated string of options. See the mount(8) man page for possible options and their meanings.
At the moment,
-o is only here for
compatibility reasons, but no use is made of supplied options.
-Kis used, specify the saltfile.
An example fstab(5) entry is:
/tmp/cryptimg /dev/vnd0c vnd rw,noauto,-k 0 0 /dev/vnd0a /mnt ffs rw,noauto 0 0
mount_vnd command first appeared in
|April 23, 2020||OpenBSD-current|