|LPD(8)||System Manager's Manual||LPD(8)|
lpd — line printer
lpd is the line printer daemon (spool area
handler) and is normally invoked at boot time from the
rc(8) file. It makes a single pass through
the printcap(5) file to find out about
the existing printers and prints any files left after a crash. It then uses
the system calls listen(2) and
accept(2) to receive requests to print
files in the queue, transfer files to the spooling area, display the queue,
or remove jobs from the queue. In each case, it forks a child to handle the
request so the parent can continue to listen for more requests.
The options are as follows:
-soption is not specified,
lpdwill listen on all network interfaces for incoming TCP connections. The
-boption, followed by a bind-address specifies that
lpdshould listen on that address instead of INADDR_ANY. Multiple
-boptions are permitted, allowing a list of addresses to be specified. Use of this option silently overrides the
-soption if it is also present on the command line. bind-address can be a numeric host name in IPV4 or IPV6 notation, or a symbolic host name which will be looked up in the normal way.
-doption turns on the
SO_DEBUGsocket(2) option. See setsockopt(2) for more details.
lpdto log valid requests received from the network. This can be useful for debugging purposes.
-nflag sets maxchild as the maximum number of child processes that
lpdwill spawn. The default is 32.
-rflag allows the “of” filter to be used if specified for a remote printer. Traditionally,
lpdwould not use the output filter for remote printers.
-sflag selects “secure” mode, in which
lpddoes not listen on a TCP socket but only takes commands from a UNIX-domain socket. This is valuable when the machine on which
lpdruns is subject to attack over the network and it is desired that the machine be protected from attempts to remotely fill spools and similar attacks.
-wflag sets maxwait as the wait time (in seconds) for dead remote server detection. If no response is returned from a connected server within this period, the connection is closed and a message logged. The default is 300 seconds.
If the port parameter is passed,
lpd listens on this port instead of the usual
“printer/tcp” port from
Access control is provided by two means. First, all requests must come from one of the machines listed in the file /etc/hosts.lpd, one hostname per line. A plus "+" may be used as a wildcard to grant access to all hosts. Second, if the “rs” capability is specified in the printcap(5) entry for the printer being accessed, lpr requests will only be honored for those users with accounts on the machine with the printer.
lpd performs reverse DNS lookups on
network clients. If a client hostname cannot be determined from its IP
address, the print request will be silently dropped. This is important to
note when debugging print problems in dynamic address environments.
The file minfree in each spool directory contains the number of disk blocks to leave free so that the line printer queue won't completely fill the disk. The minfree file can be edited with your favorite text editor.
The daemon begins processing files after it has successfully set the lock for exclusive access (described a bit later), and scans the spool directory for files beginning with cf. Lines in each cf file specify files to be printed or non-printing actions to be performed. Each such line begins with a key character to specify what to do with the remainder of the line.
If a file cannot be opened, a message will be logged via
syslog(3) using the
try up to 20 times to reopen a file it expects to be there, after which it
will skip the file to be printed.
flock(2) to provide exclusive access to
the lock file and to prevent multiple daemons from becoming active
simultaneously. If the daemon should be killed or die unexpectedly, the lock
file need not be removed. The lock file is kept in a readable ASCII form and
contains two lines. The first is the process ID of the daemon and the second
is the control file name of the current job being printed. The second line
is updated to reflect the current status of
the programs lpq(1) and
4.3BSD Line Printer Spooler Manual.
lpd daemon appeared in
Version 5 AT&T UNIX.
lpd previously required that clients
connected using a privileged port (below 1024). This restriction was removed
because it does not provide additional security and also because many modern
clients connect using an unprivileged port.
|February 8, 2020||OpenBSD-current|