|DAILY(8)||System Manager's Manual||DAILY(8)|
monthly — periodic system
The three files /etc/daily, /etc/weekly, and /etc/monthly are shell scripts run on a periodic basis by the clock daemon, cron(8). They take care of some basic administrative tasks. Their output, if any, is mailed to root.
Note: The scripts are all run as part of root's crontab(5). However, it is strongly suggested that the root mail account be an alias that forwards messages to a real user or set of users. Otherwise, root's mail will simply accumulate in /var/mail until the partition holding it runs out of space. See newaliases(8) for further details.
These scripts should not be altered. Local additions should be made to the files /etc/daily.local, /etc/weekly.local, and /etc/monthly.local, which will be executed by /etc/daily, /etc/weekly, and /etc/monthly, respectively. The *.local files are executed first, which makes it convenient to do any necessary cleanup and backup and to define any required shell variables before the script is run.
This script is run daily. It currently does the following:
ROOTBACKUPmust be set. For example, the following can be added to /etc/daily.local:
/dev/wd0j /altroot ffs xx 0 0
CALENDARis set to 0 in /etc/daily.local or the host is a yp(8) client.
CHECKFILESYSTEMSis set to 1 in /etc/daily.local, runs fsck(8) with the no-write flag (
This script is run weekly. It currently does the following:
LOGINACCOUNTINGis set to 1 in /etc/weekly.local and the /var/log/wtmp file exists, show individual users' login via the ac(8) utility.
This script is run monthly. It currently does the following:
The following variables can be set in /etc/daily.local:
The following variables can be set in /etc/weekly.local:
monthly scripts first appeared in
4.3BSD-Reno. This manual page first appeared in
If the host machine is not running 24/7, these scripts may never be run. Adjusting the time fields in the system crontab(5) may partially alleviate this problem.
Be careful when adding local additions. Services such as "www" have their own users, and should be run as such, not as root. It may be more appropriate to create a separate crontab(5) for such services.
|July 26, 2020||OpenBSD-current|