|MPW(4)||Device Drivers Manual||MPW(4)|
mpwinterface is used to create an MPLS Ethernet layer 2 tunnel between two points.
mpw interface can be created at runtime
using the ifconfig
create command or by setting up a
hostname.if(5) configuration file
for netstart(8). The interface itself
can be configured with ifconfig(8).
The local MPLS label, the remote MPLS label and neighbor, use of pseudowire control words, or flow-aware transport are normally configured after negotiation with a remote system using ldpd(8), but it is also possible to configure them manually using ifconfig(8).
# ifconfig mpw5 create # ifconfig mpw5 mplslabel 20 pweneighbor 21 10.254.0.1 # ifconfig mpw5 up
Enable the use of the Pseudowire Emulation Edge-to-Edge (PWE3) Control Word, and disable the use of a Flow label for Flow-Aware Transport of Pseudowires:
# ifconfig mpw5 pwecw -pwefat
S. Bryant and P. Pate, Pseudo Wire Emulation Edge-to-Edge (PWE3) Architecture, RFC 3985, March 2005.
S. Bryant, G. Swallow, and L. Martini, Pseudowire Emulation Edge-to-Edge (PWE3) Control Word for Use over an MPLS PSN, RFC 4385, February 2005.
S. Bryant, C. Filsfils, U. Drafz, V. Kompella, J. Regan, and S. Amante, Flow-Aware Transport of Pseudowires over an MPLS Packet Switched Network, RFC 6391, November 2011.
mpwkernel interface first appeared in OpenBSD 5.8.
mpwdriver was written by Rafael Zalamena <email@example.com>.
|March 11, 2019||OpenBSD-current|