|XEN(4)||Device Drivers Manual||XEN(4)|
xen — Xen domU
xen0 at pvbus?
xen driver performs HVM domU guest
initialization, provides abstraction for virtual Xen interrupts, access to
the XenStore configuration storage as well as a device probing facility for
paravirtualized devices such as disk and network interfaces.
ostype=$(sysctl -n kern.ostype) osrelease=$(sysctl -n kern.osrelease) # XenServer Tools version hostctl attr/PVAddons/MajorVersion 6 hostctl attr/PVAddons/MinorVersion 2 hostctl attr/PVAddons/MicroVersion 0 hostctl attr/PVAddons/BuildVersion 76888 hostctl attr/PVAddons/Installed 1 # OS version hostctl data/os_name "$ostype $osrelease" hostctl data/os_uname $osrelease hostctl data/os_distro $ostype # Inform Xen of IPs bound to the VM hostctl attr/vif/0/ipv4/0 192.0.2.1 hostctl attr/vif/0/ipv6/0 2001:db8::1 # Update XenStore hostctl data/updated 1
xen driver first appeared in
xen driver was written by
from scratch, inspired by the FreeBSD
|October 21, 2021||OpenBSD-current|