|WITNESS(4)||Device Drivers Manual||WITNESS(4)|
witnessmodule keeps track of the locks acquired and released by each thread. It also keeps track of the order in which locks are acquired with respect to each other. Each time a lock is acquired,
witnessuses these two lists to verify that a lock is not being acquired in the wrong order. If a lock order violation is detected, then a message is printed to the kernel console detailing the locks involved and the locations in question.
witness code also checks various other
conditions such as verifying that one does not recurse on a non-recursive
lock, or attempt an upgrade on a shared lock held by another thread. If any
of these checks fail, then the kernel will panic.
The behaviour of
witness is controlled by
sysctl(8) variable. Valid values for it
witnesscode first appeared in BSD/OS 5.0 and was imported from there into FreeBSD 5.0. The OpenBSD port was derived from FreeBSD and first appeared in OpenBSD 6.2.
|January 29, 2019||OpenBSD-current|