|WATCHDOGD(8)||System Manager's Manual||WATCHDOGD(8)|
watchdogdis a daemon to activate and periodically retrigger the watchdog(4) timer device from userland.
watchdogdis designed to work in high load environments, where other methods (such as a shell script invoking sysctl(8)) would involve too much overhead. The basic premise is that after every interval seconds,
watchdogdresets the hardware timer to period. See also watchdog(4) for more information on how watchdog timers work. The options are as follows:
watchdogdwill run in the foreground.
watchdogdshould retrigger the hardware timer. If no interval is specified, the value of period (see below) divided by three is used.
watchdogdwill not output a warning message if the underlying hardware adjusted the timeout period.
watchdogdprogram first appeared in OpenBSD 3.8.
watchdogdwas written by Marc Balmer <firstname.lastname@example.org>.
|July 16, 2013||OpenBSD-current|