|VIPW(8)||System Manager's Manual||VIPW(8)|
vipwedits the password file after setting the appropriate locks, and does any necessary processing after the password file is unlocked. If the password file is already locked for editing by another user,
vipwwill ask you to try again later. The default editor for
vipw performs a number of consistency
checks on the password entries, and will not allow a password file with a
“mangled” entry to be installed. If
vipw rejects the new password file, the user is
prompted to re-enter the edit session.
Once the information has been verified,
pwd_mkdb(8) to update the user
database. This is run in the background and, at very large sites, could take
several minutes. Until this update is completed, the password file is
unavailable for other updates and the new information is not available to
Which type of cipher is used to encrypt the password information depends on the configuration in login.conf(5).
EDITORwill be invoked instead of the default editor vi(1).
vipwcommand appeared in 4.0BSD.
|August 14, 2016||OpenBSD-current|