|VIASIO(4)||Device Drivers Manual||VIASIO(4)|
viasio* at isa? port 0x2e flags 0x0000
viasio* at isa? port 0x4e flags 0x0000
viasiodriver provides support for the VIA VT1211 LPC Super I/O IC. The hardware monitoring and watchdog timer functions are currently supported.
The hardware monitor provides hardware monitoring capabilities to be used with the sysctl(8) interface. The following monitoring sensors are available:
||uK||Pentium II type thermal diode|
||uK or uV DC||CPU temperature|
||uK or uV DC||System temperature|
||uK or uV DC||CPU core voltage|
||uK or uV DC||+5V|
||uK or uV DC||+12V|
If the hardware monitor is not enabled by firmware, the driver can try to enable it if value 0x0001 is present in the flags. Note that enabling the hardware monitor can lead to unexpected results.
The watchdog timer provides a standard watchdog(4) interface. If the watchdog timer is not enabled by firmware, the driver can try to enable it if value 0x0002 is present in the flags.
viasiodriver first appeared in OpenBSD 3.8.
viasiodriver was written by Alexander Yurchenko <firstname.lastname@example.org>.
|July 16, 2013||OpenBSD-current|