|ONERNG(4)||Device Drivers Manual||ONERNG(4)|
uonerng* at uhub?
uonerngdriver provides support for the Moonbase Otago OneRNG, a USB true random number generator (TRNG).
uonerngreads raw entropy from the OneRNG and uses enqueue_randomness(9) to add it to the system entropy pool.
The OneRNG is capable of operating in one of several modes, some of which are intended for production use and some of which are for testing and validating the hardware.
uonerng operates in the “Avalanche
noise with whitener” mode, which is also the manufacturer's default
Moonbase Otago: http://onerng.info/onerng
uonerngdriver first appeared in OpenBSD 5.9.
uonerngdriver was written by Devin Reade <firstname.lastname@example.org>.
uonerngdriver does not perform nor support this action. In order to currently perform such a validation, it would be necessary to disable
uonerngin the kernel and then download the firmware via the OneRNG's emulated AT modem command set.
|April 28, 2018||OpenBSD-current|