|UDP(4)||Device Drivers Manual||UDP(4)|
udp — Internet
User Datagram Protocol
UDP is a simple, unreliable datagram protocol which is used to
SOCK_DGRAM abstraction for the Internet
protocol family. UDP sockets are connectionless, and are normally used with
the sendto(2) and
recvfrom(2) calls, though the
connect(2) call may also be used to fix
the destination for future packets (in which case the
write(2) system calls may be used).
UDP address formats are identical to those used by TCP. In particular UDP provides a port identifier in addition to the normal Internet address format. Note that the UDP port space is separate from the TCP port space (i.e. a UDP port may not be “connected” to a TCP port). In addition broadcast packets may be sent (assuming the underlying network supports this) by using a reserved “broadcast address”; this address is network interface dependent.
A socket operation may fail with one of the following errors returned:
udp protocol appeared in
|September 10, 2015||OpenBSD-current|