|TRACEROUTE(8)||System Manager's Manual||TRACEROUTE(8)|
traceroute6 — print the
route packets take to network host
The Internet is a large and complex aggregation of network
hardware, connected together by gateways. Tracking the route packets follow
(or finding the miscreant gateway that's discarding packets) can be
traceroute6 attempt to elicit
TIME_EXCEEDED responses from each gateway along the
path to host, in order to determine their route.
traceroute is used for IPv4 networks and
traceroute6 for IPv6.
The options are as follows:
-pflag (or 33434 if none is specified).
traceroute. The default is 1 (skip no hosts).
traceroutehopes that nothing is listening on UDP ports base to base+nhops*nqueries-1 at the destination host (so an ICMP
PORT_UNREACHABLEmessage will be returned to terminate the route tracing). If something is listening on a port in the default range, this option can be used to pick an unused port range.
reliability, or one of the DiffServ Code Points:
af11 ... af43,
cs0 ... cs7; or a number in either hex or decimal. The default is zero. This option can be used to see if different types-of-service result in different paths. If this option is used, changes to the type-of-service in the returned packets are displayed. Not all values of TOS are legal or meaningful - see the IP spec for definitions. Useful values are probably
UNREACHABLEs are listed.
The program attempts to trace the route an IP packet would follow
to a host by launching UDP probe packets with a small TTL or hop limit, then
listening for an ICMP "time exceeded" reply from a gateway. It
starts using probes with a TTL/hop limit of one and increases by one until
it gets an ICMP "port unreachable" (which means it reached the
host) or hits a maximum limit (which defaults to 64, but can be changed
-m option). Three probes (the exact number
can be changed using the
-q option) are sent and a
line is printed showing the TTL or hop limit, address of the gateway, and
round trip time of each probe. If the probe answers come from different
gateways, the address of each responding system will be printed. If there is
no response within a 5 second timeout interval (which can be changed using
-w option), a "*" is printed for that
We don't want the destination host to process the UDP probe
packets so the destination port is set to an unlikely value (if some clod on
the destination is using that value, it can be changed using the
A sample use and output might be:
$ traceroute nis.nsf.net. traceroute to nis.nsf.net (188.8.131.52), 64 hops max, 56 byte packet 1 helios.ee.lbl.gov (184.108.40.206) 19 ms 19 ms 0 ms 2 lilac-dmc.Berkeley.EDU (220.127.116.11) 39 ms 39 ms 19 ms 3 lilac-dmc.Berkeley.EDU (18.104.22.168) 39 ms 39 ms 19 ms 4 ccngw-ner-cc.Berkeley.EDU (22.214.171.124) 39 ms 40 ms 39 ms 5 ccn-nerif22.Berkeley.EDU (126.96.36.199) 39 ms 39 ms 39 ms 6 188.8.131.52 (184.108.40.206) 40 ms 59 ms 59 ms 7 220.127.116.11 (18.104.22.168) 59 ms 59 ms 59 ms 8 22.214.171.124 (126.96.36.199) 99 ms 99 ms 80 ms 9 188.8.131.52 (184.108.40.206) 139 ms 239 ms 319 ms 10 220.127.116.11 (18.104.22.168) 220 ms 199 ms 199 ms 11 nic.merit.edu (22.214.171.124) 239 ms 239 ms 239 ms
Note that lines 2 & 3 are the same. This is due to a buggy kernel on the 2nd hop system - lbl-csam.arpa - that forwards packets with a zero TTL (a bug in the distributed version of 4.3BSD). Note that you have to guess what path the packets are taking cross-country since the NSFNET (129.140) doesn't supply address-to-name translations for its NSSes.
A more interesting example is:
$ traceroute allspice.lcs.mit.edu. traceroute to allspice.lcs.mit.edu (126.96.36.199), 64 hops max 1 helios.ee.lbl.gov (188.8.131.52) 0 ms 0 ms 0 ms 2 lilac-dmc.Berkeley.EDU (184.108.40.206) 19 ms 19 ms 19 ms 3 lilac-dmc.Berkeley.EDU (220.127.116.11) 39 ms 19 ms 19 ms 4 ccngw-ner-cc.Berkeley.EDU (18.104.22.168) 19 ms 39 ms 39 ms 5 ccn-nerif22.Berkeley.EDU (22.214.171.124) 20 ms 39 ms 39 ms 6 126.96.36.199 (188.8.131.52) 59 ms 119 ms 39 ms 7 184.108.40.206 (220.127.116.11) 59 ms 59 ms 39 ms 8 18.104.22.168 (22.214.171.124) 80 ms 79 ms 99 ms 9 126.96.36.199 (188.8.131.52) 139 ms 139 ms 159 ms 10 184.108.40.206 (220.127.116.11) 199 ms 180 ms 300 ms 11 18.104.22.168 (22.214.171.124) 300 ms 239 ms 239 ms 12 * * * 13 126.96.36.199 (188.8.131.52) 259 ms 499 ms 279 ms 14 * * * 15 * * * 16 * * * 17 * * * 18 ALLSPICE.LCS.MIT.EDU (184.108.40.206) 339 ms 279 ms 279 ms
Note that the gateways 12, 14, 15, 16 & 17 hops away either don't send ICMP "time exceeded" messages or send them with a TTL too small to reach us. 14 - 17 are running the MIT C Gateway code that doesn't send "time exceeded"s. God only knows what's going on with 12.
The silent gateway 12 in the above may be the result of a bug in the 4. BSD network code (and its derivatives): 4.x (x <= 3) sends an unreachable message using whatever TTL remains in the original datagram. Since, for gateways, the remaining TTL is zero, the ICMP "time exceeded" is guaranteed to not make it back to us. The behavior of this bug is slightly more interesting when it appears on the destination system:
1 helios.ee.lbl.gov (220.127.116.11) 0 ms 0 ms 0 ms 2 lilac-dmc.Berkeley.EDU (18.104.22.168) 39 ms 19 ms 39 ms 3 lilac-dmc.Berkeley.EDU (22.214.171.124) 19 ms 39 ms 19 ms 4 ccngw-ner-cc.Berkeley.EDU (126.96.36.199) 39 ms 40 ms 19 ms 5 ccn-nerif35.Berkeley.EDU (188.8.131.52) 39 ms 39 ms 39 ms 6 csgw.Berkeley.EDU (184.108.40.206) 39 ms 59 ms 39 ms 7 * * * 8 * * * 9 * * * 10 * * * 11 * * * 12 * * * 13 rip.Berkeley.EDU (220.127.116.11) 59 ms ! 39 ms ! 39 ms !
Notice that there are 12 "gateways" (13 is the final
destination) and exactly the last half of them are "missing".
What's really happening is that rip (a Sun-3 running Sun OS3.5) is using the
TTL from our arriving datagram as the TTL in its ICMP reply. So, the reply
will time out on the return path (with no notice sent to anyone since ICMPs
aren't sent for ICMPs) until we probe with a TTL that's at least twice the
path length. That is, rip is really only 7 hops away. A reply that returns
with a TTL of 1 is a clue this problem exists.
traceroute prints a "!" after the time if
the TTL is <= 1. Since vendors ship a lot of obsolete (DEC's Ultrix, Sun
3.x) or non-standard (HP-UX) software, expect to see this problem frequently
and/or take care picking the target host of your probes.
Other possible annotations after the time are
!H, !N, !P (got a
host, network or protocol unreachable, respectively), !A,
!C (access to the network or host, respectively, is
prohibited), !X (communication administratively prohibited
by filtering), !S or !F (source route
failed or fragmentation needed - neither of these should ever occur and the
associated gateway is busted if you see one), !U
(destination network or host unknown), !T (destination
network or host unreachable for TOS), !<code> (other
ICMP unreachable code). TOS=xxx! (TOS bit in returned
packet differs from last hop). If almost all the probes result in some kind
traceroute will give up and
$ traceroute -g 10.3.0.5 18.104.22.168
will show the path from the Cambridge Mailbridge to PSC, while
$ traceroute -g 22.214.171.124 -g 10.3.0.5 126.96.36.199
will show the path from the Cambridge Mailbridge to Merit, using PSC to reach the Mailbridge.
This program is intended for use in network testing, measurement
and management. It should be used primarily for manual fault isolation.
Because of the load it could impose on the network, it is unwise to use
traceroute during normal operations or from
The very first
traceroute (never released)
used ICMP ECHO_REQUEST datagrams as probe packets. During the first night of
testing it was discovered that more than half the router vendors of the time
would not return an ICMP TIME_EXCEEDED for an ECHO_REQUEST.
traceroute was then changed to use UDP probe
packets. Most modern TCP/IP implementations will now generate an ICMP error
message to ICMP query messages, and the option to use ECHO_REQUEST probes
traceroute command first appeared in
command first appeared in the WIDE Hydrangea IPv6 protocol stack kit.
Implemented by Van Jacobson from a suggestion by Steve Deering. Debugged by a cast of thousands with particularly cogent suggestions or fixes from C. Philip Wood, Tim Seaver, and Ken Adelman.
|April 5, 2019||OpenBSD-current|