|TIME_SECOND(9)||Kernel Developer's Manual||TIME_SECOND(9)|
time_uptime — system time
extern volatile time_t time_second;
extern volatile time_t time_uptime;
The time_uptime variable is a monotonically increasing system clock. It is set at boot, and is updated by the periodic timer interrupt. (It is not updated by settimeofday(2).)
All of these variables contain times expressed in seconds since midnight (0 hour), January 1, 1970.
Clock interrupts should be blocked when reading or writing time_second or time_uptime, because those variables are updated by hardclock(9).
|April 3, 2016||OpenBSD-current|