OpenBSD manual page server

Manual Page Search Parameters

TCP(4) Device Drivers Manual TCP(4)

tcpInternet Transmission Control Protocol

#include <sys/socket.h>
#include <netinet/in.h>
#include <netinet/tcp.h>

int
socket(AF_INET, SOCK_STREAM, 0);

int
socket(AF_INET6, SOCK_STREAM, 0);

The TCP protocol provides a reliable, flow-controlled, two-way transmission of data. It is a byte-stream protocol used to support the SOCK_STREAM abstraction. TCP uses the standard Internet address format and, in addition, provides a per-host collection of “port addresses”. Thus, each address is composed of an Internet address specifying the host and network, with a specific TCP port on the host identifying the peer entity.

Sockets utilizing the TCP protocol are either “active” or “passive”. Active sockets initiate connections to passive sockets. By default TCP sockets are created active; to create a passive socket the listen(2) system call must be used after binding the socket with the bind(2) system call. Only passive sockets may use the accept(2) call to accept incoming connections. Only active sockets may use the connect(2) call to initiate connections.

Passive sockets may “underspecify” their location to match incoming connection requests from multiple networks. This technique, termed “wildcard addressing”, allows a single server to provide service to clients on multiple networks. To create a socket which listens on all networks, the Internet address INADDR_ANY must be bound. The TCP port may still be specified at this time; if the port is not specified the system will assign one. Once a connection has been established, the socket's address is fixed by the peer entity's location. The address assigned to the socket is the address associated with the network interface through which packets are being transmitted and received. Normally this address corresponds to the peer entity's network.

TCP supports several socket options which are set with setsockopt(2) and tested with getsockopt(2).

TCP_INFO
Retrieve information about a socket's underlying TCP session. TCP_INFO is only used with (). The argument is a pointer to an instance of struct tcp_info (from <netinet/tcp.h>).
TCP_NODELAY
Under most circumstances, TCP sends data when it is presented; when outstanding data has not yet been acknowledged, it gathers small amounts of output to be sent in a single packet once an acknowledgement is received. For a small number of clients, such as window systems that send a stream of mouse events which receive no replies, this packetization may cause significant delays. Therefore, TCP provides a boolean option, TCP_NODELAY (from <netinet/tcp.h>), to defeat this algorithm.
TCP_NOPUSH
By convention, the TCP sender will set the “push” bit and begin transmission immediately (if permitted) at the end of every user call to write(2) or writev(2). When this option is set to a non-zero value, TCP will delay sending any data at all until either the socket is closed, the internal send buffer is filled, or this option is set to a zero value.
TCP_MAXSEG
Set the maximum segment size for this connection. The maximum segment size can only be lowered.
TCP_SACK_ENABLE
Use selective acknowledgements for this connection. See options(4).
TCP_MD5SIG
Use TCP MD5 signatures per RFC 2385. This requires Security Associations to be set up, which can be done using ipsecctl(8). When a listening socket has TCP_MD5SIG set, it accepts connections with MD5 signatures only from sources for which a Security Association is set up. Connections without MD5 signatures are only accepted from sources for which no Security Association is set up. The connected socket only has TCP_MD5SIG set if the connection is protected with MD5 signatures.

The option level for the setsockopt(2) call is the protocol number for TCP, available from getprotobyname(3).

Options at the IP transport level may be used with TCP; see ip(4) or ip6(4). Incoming connection requests that are source-routed are noted, and the reverse source route is used in responding.

A socket operation may fail with one of the following errors returned:

[EISCONN]
when trying to establish a connection on a socket which already has one;
[ENOBUFS]
when the system runs out of memory for an internal data structure;
[ETIMEDOUT]
when a connection was dropped due to excessive retransmissions;
[ECONNRESET]
when the remote peer forces the connection to be closed;
[ECONNREFUSED]
when the remote peer actively refuses connection establishment (usually because no process is listening to the port);
[EADDRINUSE]
when an attempt is made to create a socket with a port which has already been allocated;
[EADDRNOTAVAIL]
when an attempt is made to create a socket with a network address for which no network interface exists.

tcpbench(1), getsockopt(2), socket(2), inet(4), inet6(4), ip(4), ip6(4), netintro(4), ipsecctl(8), tcpdrop(8)

The tcp protocol stack appeared in 4.2BSD.

August 11, 2022 OpenBSD-current