|SWITCHD.CONF(5)||File Formats Manual||SWITCHD.CONF(5)|
switch daemon configuration file
switchd.conf is the configuration file for
the switch daemon, switchd(8).
switchd.conf files is divided into the
following main sections:
The current line can be extended over multiple lines using a backslash (‘\’). Comments can be put anywhere in the file using a hash mark (‘#’), and extend to the end of the current line. Care should be taken when commenting out multi-line text: the comment is effective until the end of the entire block.
Argument names not beginning with a letter, digit, or underscore must be quoted.
Additional configuration files can be included with the
include keyword, for example:
Macros can be defined that will later be expanded in context.
Macro names must start with a letter, digit, or underscore, and may contain
any of those characters. Macro names may not be reserved words (for example,
root). Macros are not expanded inside quotes.
ext_ip="10.0.0.1" listen on $ext_ip
The following options can be set globally:
The following example is a typical one.
listen on 0.0.0.0 port 6653
|July 11, 2019||OpenBSD-current|