|SWITCH(4)||Device Drivers Manual||SWITCH(4)|
switchdriver provides a network interface pseudo-device. The interface is the forwarding part of a network switch and it works along with a controller, usually switchd(8) or switchctl(8), through the device /dev/switchN. The
switchdevice and the controller communicate using the OpenFlow 1.3 protocol.
switch interface is created using
create or by opening the character device
/dev/switchN is the OpenFlow channel of the interface switchN. It is used for exchanging OpenFlow messages. The device behaves like a stream, which means that a read(2) may return one or more OpenFlow messages depending on the number of bytes requested. It may also read the message partially (e.g. read(2) the OpenFlow message header and then the complete message). The same applies to write(2) calls, so it may send one or more OpenFlow messages with a single write or use more than one write(2) calls to send a single message.
switchinterface responds to all of the ioctl(2) calls specific to other interfaces listed in netintro(4).
SIOCBRDGADDLstruct ifbreq *
switchdriver first appeared in OpenBSD 6.1.
switchdriver was written by Kazuya Goda <firstname.lastname@example.org>.
|May 10, 2019||OpenBSD-current|