|STI(4)||Device Drivers Manual||STI(4)|
sti* at mainbus0
sti* at pci?
sti* at phantomas0
wsdisplay* at sti?
stiwas created by HP to provide uniform frame-buffer access operations for their 9000/300 and 9000/700 series of workstations.
The following models are supported (though not all features or frame buffer depths may be available):
|Visualize EG||16||2||HP B/C-class, GSC/PCI|
|Visualize FXE||24||24||y||PCI 32/66|
|Visualize FX2||24||24||y||PCI 64/66|
|Visualize FX4/FX6||24||32||y||PCI 64/66|
Implementation consists of a set of functions burnt in to the PROM on the card and providing the following set of functions (see below for PROM revision history on functions supported by particular PROM revision):
There are two modes for accessing the PROM: “byte” and “word” mode. In “byte” mode each 4-byte word contains only the low-ordered big-endian byte of data; i.e., to compose one word of data 4 words should be read and low-ordered bytes of those should be shifted correspondingly. In “word” mode each word contains all 4 bytes of valid data.
PROM revision history:
Windows NT (tm).
GSCbus, ROM-less operation.
Visualize FXdue to rearchitecture for performance.
PCIEPROM map mode, implemented on
sti_utilfunction added (flashing under HP-UX and other sideband traffic).
Standard Text Interface For Graphics Devices, Hewlett-Packard, Revision 8.13, March 1, 2000.
stidriver was written by Michael Shalayeff <firstname.lastname@example.org> for HPPA port for OpenBSD 2.7.
|March 19, 2014||OpenBSD-current|