|ZS(4)||Device Drivers Manual (sparc64)||ZS(4)|
zs* at fhc?
zs* at sbus?
zstty* at zs?
zskbd* at zs?
wskbd* at zskbd?
zsms* at zs?
wsmouse* at zsms?
zsis a Zilog 8530 serial interface chip used in SBus-based UltraSPARC Sun workstations. The Zilog 8530 provides two input/output channels per instance. Most Sun workstations include two of these interfaces. One of the interfaces is usually hardwired for use by the keyboard and mouse attached to the workstation console. The
zskbddevices connect keyboard devices to the generic keyboard driver
zsmsdevices connect mice to the generic mouse driver wsmouse(4). The remaining additional
zsinterfaces provide RS-423 and RS-232 serial ports for general purpose use.
zs driver supports all of the standard
tty(4) ioctl calls. The status of the DTR,
RTS, CTS, and DCD signals can be queried with TIOCMGET command, but, due to
limitations in the hardware, only the DTR and RTS signals can be modified
with TIOCMSET, TIOCMBIC, and TIOCMBIS
zskbd driver supports a number of
different key mappings. By default, the layout corresponding to the keyboard
model as probed by the
zskbd driver will be used. A
different layout can be chosen either with the kernel options
“SUNKBD_LAYOUT” (for type 4 keyboards) and
“SUNKBD5_LAYOUT” (for type 5 keyboards) at compile time or
with the utility wsconsctl(8)
(variable: “keyboard.encoding”) at runtime.
Other mappings can be used if the whole keymap is replaced by means of wsconsctl(8). The built-in mappings are at this time:
The KB_SV mapping can be used in the KB_NODEAD (.nodead) variant. This switches off the “dead accents”.
wsconsctl keyboard.encoding=de. To set it at kernel build time, add the following to the kernel configuration file for a type 4 keyboard:
For a type 5 keyboard:
zsdriver first appeared in 4.4BSD. Support for the TIOCM* ioctl(2)s appeared in OpenBSD 2.3.
zsdriver now supports cua minor devices, but with this known deficiency in the simultaneous outgoing/incoming aspect of the driver: The first outgoing connection succeeds, but second and subsequent connections fail, apparently due to a getty hang. The hung getty apparently prevents the cua device from being re-opened.
The kernel does not provide a keyboard layout for all manufactured Sun keyboard models.
|November 21, 2015||OpenBSD-current|