|MGX(4)||Device Drivers Manual (sparc64)||MGX(4)|
mgx — SMS MGX and
MGXPlus accelerated 8/24-bit color frame buffers
mgx* at sbus?
wsdisplay* at mgx?
The Southland Media Systems (now Quantum 3D) MGX and MGXPlus are SBus color frame buffers, with graphics acceleration capabilities.
mgx driver interfaces the frame buffer
with the wscons(4) console framework. It
does not provide direct device driver entry points but makes its functions
available via the internal
The MGX and MGXPlus frame buffers will adapt their resolution to the monitor they are connected to. However, when not connected to a Sun monitor, the device will default to the cgthree(4)-compatible 1152x900 resolution, with a refresh rate of 66Hz. A different resolution can be forced using the set of DIP switches (sometimes covered by metal foil) located near the SBus connector on the board itself.
The DIP switch settings are as follows:
|1 2 3 4|
All other combinations are unsupported and may damage the hardware.
This driver does not support mode switching at the moment, and drives the card in PROM-compatible, 8 bit, mode only.
|December 3, 2011||OpenBSD-current|