|SLAACD(8)||System Manager's Manual||SLAACD(8)|
slaacdis a stateless address autoconfiguration (SLAAC) daemon for clients. It listens for IPv6 router advertisement messages, for example those sent by rad(8), on interfaces with the AUTOCONF6 flag set.
slaacdderives IPv6 addresses and default routes from received router advertisements and installs them in the kernel. See hostname.if(5) and ifconfig(8) on how to enable auto configuration on an interface.
slaacd monitors network interface states
(interface going up or down, auto configuration enabled or disabled etc.)
and sends router solicitations when necessary.
slaacd can be controlled with
the slaacctl(8) utility.
The options are as follows:
slaacdwill run in the foreground and log to stderr.
-voptions increase the verbosity.
R. Hinden and S. Deering, IP Version 6 Addressing Architecture, RFC 4291, February 2006.
T. Narten, E. Nordmark, W. Simpson, and H. Soliman, Neighbor Discovery for IP version 6 (IPv6), RFC 4861, September 2007.
T. Narten, R. Draves, and S. Krishnan, Privacy Extensions for Stateless Address Autoconfiguration in IPv6, RFC 4941, September 2007.
F. Gont, A Method for Generating Semantically Opaque Interface Identifiers with IPv6 Stateless Address Autoconfiguration (SLAAC), RFC 7217, April 2014.
A. Yourtchenko and L. Colitti, Reducing Energy Consumption of Router Advertisements, RFC 7772, February 2016.
F. Gont, A. Cooper, D. Thaler, and W. Liu, Recommendation on Stable IPv6 Interface Identifiers, RFC 8064, February 2017.
J. Jeong, S. Park, L. Beloeil, and S. Madanapalli, IPv6 Router Advertisement Options for DNS Configuration, RFC 8106, March 2017.
slaacdprogram first appeared in OpenBSD 6.2.
slaacdprogram was written by Florian Obser <firstname.lastname@example.org>.
|July 23, 2018||OpenBSD-current|