|skgpio(4/amd64)||Soekris net6501 GPIO and LEDs|
|skgpio(4/i386)||Soekris net6501 GPIO and LEDs|
|SKGPIO(4)||Device Drivers Manual (amd64)||SKGPIO(4)|
skgpio — Soekris
net6501 GPIO and LEDs
skgpio0 at isa? port 0x680
gpio* at skgpio?
skgpio driver provides support for the
GPIO and LEDs as implemented by the Xilinx Spartan FGPA integrated into the
Soekris net6501 programmed with the default bitstream found in the BIOS.
Two standard gpio(4) interfaces are provided, one for the 16 real pins which can be configured as either inputs or outputs and another with 2 output-only pins that map to the error and ready LEDs respectively. Both may be used with gpioctl(8).
skgpio driver first appeared in
skgpio driver was written by
If the Xilinx FPGA is programmed with a different bitstream, the driver will likely not function.
|October 22, 2015||OpenBSD-current|