|GIO(4)||Device Drivers Manual (sgi)||GIO(4)|
gio0 at imc0
giobus is a bus for connecting high-speed peripherals to the main memory and CPU. The devices themselves are typically (but not necessarily) connected to the hpc(4) peripheral controller, and memory and CPU are accessed through the imc(4) system controller. The
giobus is found on the Indigo, Indy, Challenge S, Challenge M, and Indigo2 machines and exists in three incarnations: GIO32, GIO32-bis, and GIO64.
The devices currently supported under OpenBSD are:
gioDMA-capable expansion card, despite having two slots. Cards based on the hpc(4) controller, such as the GIO32 SCSI and E++ Ethernet adapters, must be placed in slot 1 (closest to the side of the case). All other cards must be placed in slot 0 (adjacent to the memory banks).
Indigo2 and Challenge M systems contain either three or four GIO64
connectors, depending on the model. However, in both cases only two
electrically distinct slots are present. Therefore, distinct expansion cards
may not share physical connectors associated with the same slot. On the
other hand, these apparently redundant slot connectors allow multiple board
assemblies to draw more power from the bus, and also helps mix
gio and EISA boards in the same chassis. In all
systems, the upper two GIO64 connectors are GIO slot 1, while the lower
connectors (either one or two of them) are GIO slot 0.
|April 18, 2012||OpenBSD-current|