|RTADVD(8)||System Manager's Manual||RTADVD(8)|
] interface ...
rtadvdsends router advertisement packets to the specified interfaces. The program will daemonize itself on invocation. It will then send router advertisement packets periodically, as well as in response to router solicitation messages sent by end hosts. Router advertisements can be configured on a per-interface basis, as described in rtadvd.conf(5). If there is no configuration file entry for an interface, or if the configuration file does not exist at all,
rtadvdsets all the parameters to their default values. In particular,
rtadvdreads all the interface routes from the routing table and advertises them as on-link prefixes.
rtadvdalso watches the routing table. By default, if an interface direct route is added/deleted on an advertising interface and no static prefixes are specified by the configuration file,
rtadvdadds/deletes the corresponding prefix to/from its advertising list, respectively. The
-soption may be used to disable this behavior. Moreover, if the status of an advertising interface changes,
rtadvdwill start or stop sending router advertisements according to the latest status. Basically, hosts MUST NOT send Router Advertisement messages at any time (RFC 4861, Section 6.2.4). However, it would sometimes be useful to allow hosts to advertise some parameters such as prefix information and link MTU. Thus,
rtadvdcan be invoked if router lifetime is explicitly set to zero on every advertising interface. The command line options are:
rtadvdwill run in the foreground and log to stderr.
rtadvdwill dump the current internal state into syslog(3). Use
rtadvdgracefully. In this case,
rtadvdwill transmit router advertisement with router lifetime 0 to all the interfaces (in accordance with RFC 4861 6.2.5).
rtadvdutility exits 0 on success, and >0 if an error occurs. rtadvd.conf(5), slaacd(8), syslogd(8)
rtadvdcommand first appeared in the WIDE Hydrangea IPv6 protocol stack kit.
rtadvdadvertise Router Advertisement messages on an upstream link to avoid undesirable icmp6(4) redirect messages. However, based on later discussion in the IETF IPng working group, all routers should rather advertise the messages regardless of the network topology, in order to ensure reachability.
|September 14, 2017||OpenBSD-current|