|RPC.LOCKD(8)||System Manager's Manual||RPC.LOCKD(8)|
rpc.lockd — NFS
file locking daemon
rpc.lockd is a daemon which provides file-
and record-locking services in an NFS environment.
The options are as follows:
LOG_DAEMON. If debug_level is not specified, level 1 is assumed, giving one log line per protocol operation. Higher debug levels can be specified, causing display of operation arguments and internal operations of the daemon.
rpc.lockdonly accepts requests from hosts which are reinitialising locks which existed before the server restart. The default is 30 seconds.
Error conditions are logged to syslog, irrespective of the debug
level, using log level
LOG_ERR and facility
rpc.lockd daemon must NOT be invoked
by inetd(8) because the protocol assumes
that the daemon will run from system start time. Instead, it should be run
from rc(8) after the network has been
The implementation is based on the specification in X/Open CAE Specification C218, "Protocols for X/Open PC Interworking: XNFS, Issue 4", ISBN 1 872630 66 9
The current implementation provides only the server side of the protocol (i.e., clients running other OS types can establish locks on an OpenBSD fileserver, but there is currently no means for an OpenBSD client to establish locks).
The current implementation serialises lock requests that could be shared.
|June 13, 2008||OpenBSD-current|