|RENICE(8)||System Manager's Manual||RENICE(8)|
renicealters the scheduling priority of one or more running processes with ID id. Processes may be selected by process ID, process group ID, and user name or ID. If none of the
-gpuoptions are specified, the default is to select by process ID. Multiple processes can be specified in a space separated list.
Users other than the superuser may only alter the priority of
processes they own, and can only monotonically increase their “nice
value” within the range 0 to
PRIO_MAX (20), which prevents overriding
administrative fiats. The superuser may alter the priority of any process
and set the priority to any value in the range
PRIO_MIN (-20) to
Useful priorities are: 20 (the affected processes will run only when nothing else in the system wants to), 0 (the “base” scheduling priority), anything negative (to make things go very fast).
The options are as follows:
-nis omitted and increment is the first argument to
renice, then increment is taken as an absolute priority rather than an increment.
reniceutility exits 0 on success, and >0 if an error occurs.
# renice -n +1 987 -u daemon root -p 32
reniceutility is compliant with the IEEE Std 1003.1-2008 (“POSIX.1”) specification, except the way in which processes are specified differs.
The historical behavior of passing increment as an absolute priority is supported for backwards compatibility.
renicecommand appeared in 4.0BSD.
|May 15, 2015||OpenBSD-current|