|RC.SHUTDOWN(8)||System Manager's Manual||RC.SHUTDOWN(8)|
Firstly it saves random data for reseeding the kernel random
number generator during the next boot. It then stops any daemons defined in
the pkg_scripts variable in
rc.conf.local(8), by passing them
rc(8) then runs
rc.shutdown. The administrator should place in this
file any commands they wish to have executed during shutdown.
Finally, all carp(4) interfaces are brought down and then the system shuts down.
If init(8) is exiting single-user mode it will also run the first part of shutdown (saving random data), though not the latter.
|July 13, 2017||OpenBSD-current|