|RAD(8)||System Manager's Manual||RAD(8)|
radis an IPv6 router advertisement daemon. It periodically sends IPv6 router advertisement messages with prefix and default router information. Clients like slaacd(8) use these to configure IPv6 addresses on network interfaces and set default routes. Additionally it listens for IPv6 router solicitation messages and responds with router advertisements.
rad is usually started at boot time, and
can be enabled by setting the following in
rad can be controlled with the
The options are as follows:
radwill run in the foreground and log to stderr.
R. Hinden and S. Deering, IP Version 6 Addressing Architecture, RFC 4291, February 2006.
T. Narten, E. Nordmark, W. Simpson, and H. Soliman, Neighbor Discovery for IP version 6 (IPv6), RFC 4861, September 2007.
A. Yourtchenko and L. Colitti, Reducing Energy Consumption of Router Advertisements, RFC 7772, February 2016.
J. Jeong, S. Park, L. Beloeil, and S. Madanapalli, IPv6 Router Advertisement Options for DNS Configuration, RFC 8106, March 2017.
radprogram first appeared in OpenBSD 6.4.
radprogram was written by Florian Obser <email@example.com>.
radon a carp(4) interface, it is recommended to either disable SOIIs (persistent Semantically Opaque Interface Identifiers) on the interface with ifconfig(8), or ensure that all CARP peers have the same SOII key stored in /etc/soii.key. Otherwise the default IPv6 router's link-local address will change during CARP failover, which temporarily disrupts connectivity of IPv6 autoconf clients.
|January 2, 2019||OpenBSD-current|