|PWDOG(4)||Device Drivers Manual||PWDOG(4)|
pwdog0 at pci?
pwdogdriver provides support for Quancom PWDOG1 boards.
If the kernel crashes, the watchdog timer is not reset and the system will reboot (assuming a proper connection is made between the PWDOG1 and the motherboard). Alternatively, the watchdog can be reinitialized via a userland process which ensures that process scheduling, not just kernel timeout processing, is still taking place. See watchdog(4) and watchdogd(8) for more information.
The timeout period of the PWDOG1 card is set using DIP switches and cannot be changed by software.intro(4), pci(4), watchdog(4), watchdogd(8)
pwdogdriver first appeared in OpenBSD 4.1.
pwdogdriver was written by Marc Balmer <firstname.lastname@example.org>.
|July 16, 2013||OpenBSD-current|