OpenBSD manual page server

Manual Page Search Parameters

PPPX(4) Device Drivers Manual PPPX(4)

pppx, pppacPPP multiplexer device

pseudo-device pppx


#include <sys/socket.h>
#include <sys/ioctl.h>
#include <net/pipex.h>

The pppx and pppac drivers works with the npppd(8) daemon to provide network interfaces for Point-to-Point Protocol (PPP) sessions by request from the daemon. pppx operates by allocating a network interface for each PPP session. pppac concentrates multiple PPP sessions on a single network interface. The interfaces also work with pipex(4) to accelerate the performance of data packet forwarding, and supports ioctls which are added by pipex(4).

To use pppx or pppac from npppd(8) the administrator needs to configure the interface configuration in npppd.conf(5). Also the administrator needs to enable pipex(4) by setting net.pipex.enable to ‘1’ using sysctl(8).

inet(4), inet6(4), pipex(4), hostname.if(5), npppd.conf(5), netstart(8), npppd(8), sysctl(8)

The pppx driver first appeared in OpenBSD 5.3. The pppac interface driver first appeared in OpenBSD 6.7.

David Gwynne <dlg@openbsd.org>
Claudio Jeker <claudio@openbsd.org>

January 23, 2020 OpenBSD-current