|PGT(4)||Device Drivers Manual||PGT(4)|
Conexant/Intersil Prism GT Full-MAC IEEE 802.11a/b/g
wireless network device
pgt* at cardbus?
pgt* at pci?
pgt driver provides support for
Conexant/Intersil GT-series devices which can support the Full-Mac firmware,
using the ISL3877, ISL3880, and ISL3890 chips. The
pgt driver will not (yet) work on similar devices
using the ISL3886 or similar chips which use the Soft-Mac firmware.
These are the modes the
pgt driver can
pgt driver can be configured to use
hardware Wired Equivalent Privacy (WEP). It is strongly recommended that WEP
not be used as the sole mechanism to secure wireless communication, due to
serious weaknesses in it.
In BSS mode, the driver supports powersave mode, which can be enabled via ifconfig(8).
The driver needs a set of firmware files which are loaded when an interface is brought up:
These firmware files are not free because Conexant refuses to grant distribution rights. In fact they have rebuffed thousands of attempts to start a dialogue on this issue. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to download these files on their own.
A prepackaged version of the firmware can be installed using fw_update(1).
The following cards are among those supported by the
|D-Link DWL-g650 A1||ISL3890||PCI|
|I-O Data WN-G54/CB||ISL3890||PCI|
|I4 Z-Com XG-600||ISL3890||PCI|
|I4 Z-Com XG-900||ISL3890||PCI|
|Intersil PRISM Indigo||ISL3877||PCI|
|Intersil PRISM Duette||ISL3890||PCI|
|NETGEAR WG511 (Taiwanese, not Chinese)||ISL3890||CardBus|
|SMC EZ Connect g 2.4GHz SMC2802W||ISL3890||PCI|
|SMC EZ Connect g 2.4GHz SMC2835W-v2||ISL3890||CardBus|
|ZyXEL ZyAIR G-100||ISL3890||CardBus|
The following example scans for available networks:
# ifconfig pgt0 scan
The following hostname.if(5) example configures pgt0 to join network “mynwid”, using WEP key “mywepkey”, obtaining an IP address using DHCP:
nwid mynwid nwkey mywepkey inet autoconf
The following hostname.if(5) example creates a host-based access point on boot:
mediaopt hostap nwid mynwid nwkey mywepkey inet 192.168.1.1 255.255.255.0
pgt driver first appeared in
pgt driver was originally written for
FreeBSD by Brian
Fundakowski, and then rewritten for OpenBSD
by Marcus Glocker and Claudio
Host AP mode doesn't support power saving. Clients attempting to use power saving mode may experience significant packet loss (disabling power saving on the client will fix this).
|October 15, 2021||OpenBSD-current|