|PCEXMEM(4)||Device Drivers Manual (luna88k)||PCEXMEM(4)|
— NEC PC-9801 extension board slot
pcex0 at cbus0
The file /dev/pcexmem is an mmap(2) capable interface to the memory area of the installed board at "NEC PC-9801 extension board slot" on LUNA-88K2. Byte offsets in this file are interpreted as relative memory addresses of the installed board. The range should be between 0x0 and 0xffffff.
The I/O port area of the installed board is accessed via the file /dev/pcexio in the same manner as /dev/pcexmem. The range should be between 0x0 and 0xffff.
The following ioctl(2) calls apply to /dev/pcexmem and /dev/pcexio in order to handle interrupts of this extension slot. Currently 7 levels of interrupt (0 to 6) are supported.
The /dev/pcexmem and /dev/pcexio files first appeared in OpenBSD 5.6.
|December 8, 2014||OpenBSD-current|