OpenBSD manual page server

Manual Page Search Parameters

MSTS(4) Device Drivers Manual MSTS(4)

mstsMeinberg Standard Time String timedelta sensor

pseudo-device msts [count]

This line discipline interfaces serial Meinberg devices.

The line discipline is enabled by the following sequence:

#include <sys/ioctl.h>
int ldisc = MSTSDISC, fildes; ...
ioctl(fildes, TIOCSETD, &ldisc);

The byte stream is unaltered by the line discipline which maintains a timedelta sensor using the MSTS data. The timedelta sensor will appear as msts* in the list of sensors and the delta (in nanoseconds) between the received time information and the local time can be accessed through the sysctl(8) interface.

The Meinberg radio clocks use the following default baudrates:

GPS-receivers (external and PCI, COM0)
19200/8N1
GPS-receivers (external, COM1)
9600/8N1
DCF77-receivers (external)
9600/7E2
DCF77-receivers (PCI)
4800/8N1

The quality of the timedelta is reported as the sensor status:

OK
The time information is valid. The timedelta is safe to use for applications like ntpd(8).
WARN
The attached receiver has been indicating a warning condition for at least the last ten minutes. The timedelta should be used with care.
CRITICAL
tty timestamping has been turned on but there is no PPS signal present or the receiver indicated a warning condition for at least the last twenty minutes. Check your hardware. Some receiver units need PPS to be manually turned on.

The status of a second sensor is used to report the status of the device itself:

OK
The clock is synchronized, e.g. a GPS receiver has a fix.
WARN
The device issued a warning condition, e.g. a GPS receiver has no fix.

tty(4), ldattach(8), ntpd(8), sysctl(8)

The msts interface first appeared in OpenBSD 4.3.

The msts line discipline was written by Marc Balmer <mbalmer@openbsd.org>.

January 15, 2015 OpenBSD-current