|APMD(8)||System Manager's Manual||APMD(8)|
apmdmonitors the advanced power management device, apm(4), acting on signaled events and upon user requests as sent by the apm(8) program. For suspend and standby request events delivered by the BIOS, or via apm(8),
apmdruns the appropriate configuration program (if one exists), syncs the buffer cache to disk and initiates the requested state. When resuming after suspend or standby,
apmdruns the appropriate configuration program (if one exists). When the power status changes (battery is connected or disconnected)
apmdfetches the current status and reports it via syslog(3) with logging facility
LOG_DAEMON. The options are as follows:
apmdin automatic performance adjustment mode.
apmdenters debug mode, logging to facility
LOG_LOCAL1, and stays in the foreground on the controlling terminal.
apmdin manual performance adjustment mode, initialising hw.setperf to 100.
apmdin manual performance adjustment mode, initialising hw.setperf to 0.
apmdexits without monitoring the APM status.
apmdperiodically polls the APM driver for the current power state. If the battery charge level changes substantially or the external power status changes, the new status is logged. The polling rate defaults to once per 10 minutes, but may be specified using the
-zare specified, the last one will supersede the other.
apmddoes not wait for positive confirmation that the requested state has been entered before replying to the client; to do so would mean the client does not get a reply until the system resumes from its sleep state. Rather,
apmdreplies with the intended state to the client and then places the system in the requested state after running the configuration script and flushing the buffer cache. Actions can be configured for the following transitions: suspend, hibernate, standby, resume, powerup, and powerdown. The suspend, hibernate and standby actions are run prior to
apmdperforming any other actions (such as disk syncs) and entering the new state. The resume program is run after resuming from a stand-by or suspended state. The powerup and powerdown programs are run after the power status (AC connected or not) changes, as well as after a resume (if the power status changed in the mean time).
apmdcommand first appeared in NetBSD 1.3. OpenBSD support was added in OpenBSD 1.2.
|August 29, 2017||OpenBSD-current|