|APM(8)||System Manager's Manual||APM(8)|
apmcommunicates with the Advanced Power Management daemon, apmd(8), making requests of it for current power status or to place the system into a suspend or stand-by state. With no flags,
apmdisplays the current power management state in verbose form.
The options are as follows:
commands are shortcuts for suspending and hibernating the system,
respectively. With no arguments, they are placed into their respective
states. The command line flags serve the same purpose as for
These commands do not wait for positive confirmation that the requested state has been entered; to do so would mean the command does not return until the system resumes from its sleep state.
Each system provides methods for waking from suspend or hibernate. For those machines supporting acpi(4) style suspend/resume (or hibernate/unhibernate) semantics, the wakeup devices for each sleep state are printed during system boot in dmesg(8).
The system will attempt to provide as much feedback as is possible on the specific hardware being suspended/resumed. This includes setting system LEDs or other indicators to illustrate progress throughout the suspend/resume (or hibernate/unhibernate) process. Such feedback is machine-dependent.
-fflag may be used to specify an alternate socket name. The protection modes on this socket govern which users may access the APM functions.
Advanced Power Management (APM) BIOS Interface Specification (revision 1.2), Intel Corporation and Microsoft Corporation
apmcommand appeared in NetBSD 1.3; OpenBSD support was added in OpenBSD 1.2.
|August 4, 2015||OpenBSD-current|