|MEMCONFIG(8)||System Manager's Manual||MEMCONFIG(8)|
control system cache behaviour with respect to
A number of supported system architectures allow the behaviour of the CPU cache to be programmed to behave differently depending on the region being written.
memconfig provides an interface to this
facility, allowing CPU cache behavior to be altered for ranges of system
These ranges are typically power-of-2 aligned and sized, however
the specific rules governing their layout vary between architectures. The
memconfig program does not attempt to enforce these
rules, however the system will reject any attempt to set an illegal
The operands and their options are as follows:
To clear based on ownership:
To clear based on the base/length combination:
Base and length must exactly match an existing range.
memconfig was originally introduced in
FreeBSD 3.3 as memcontrol.
|January 20, 2014||OpenBSD-current|