|MEM(4)||Device Drivers Manual (luna88k)||MEM(4)|
The file /dev/mem is an interface to the physical memory of the computer. Byte offsets in this file are interpreted as physical memory addresses. Reading and writing this file is equivalent to reading and writing memory itself. An error will be returned if an attempt is made to reference an offset outside of /dev/mem.
Kernel virtual memory is accessed via the file /dev/kmem in the same manner as /dev/mem. Only kernel virtual addresses that are currently mapped to memory are allowed.
On the luna88k, physical memory is always contiguous; kernel virtual memory begins at 0x00000000.
The /dev/mem and /dev/kmem files appeared in Version 6 AT&T UNIX.
|January 12, 2018||OpenBSD-current|