|MPBIOS(4)||Device Drivers Manual (i386)||MPBIOS(4)|
mpbios — MP
mpbios0 at bios0
mpbios driver extracts configuration
information from the BIOS on multiprocessor systems that conform to the
Intel MultiProcessor Specification. This information is used to attach
application processors and APICs, and to assign interrupts to ISA, EISA and
On modern systems this information is provided by ACPI through the
acpimadt(4) device. On such a system
mpbios will not attach, even if the BIOS also
contains the data structures specified by the Intel MP Specification.
mpbios driver supports version 1.1 and
1.4 of the Intel MP Specification.
mpbios driver first appeared in
OpenBSD 4.5, based on code present since
|January 13, 2009||OpenBSD-current|