|MEM(4)||Device Drivers Manual (i386)||MEM(4)|
The special file /dev/mem is an interface to the physical memory of the computer. Byte offsets in this file are interpreted as physical memory addresses. Reading and writing this file is equivalent to reading and writing memory itself. Only offsets within the bounds of /dev/mem are allowed.
Kernel virtual memory is accessed through the interface /dev/kmem in the same manner as /dev/mem. Only kernel virtual addresses that are currently mapped to memory are allowed.
On ISA the I/O memory space begins at physical address
0x000a0000 and runs to
0x00100000. The per-process data size for the
current process is
UPAGES long, and ends at virtual
The /dev/mem and /dev/kmem files appeared in Version 6 AT&T UNIX.
|January 12, 2018||OpenBSD-current|