|CPU(4)||Device Drivers Manual (i386)||CPU(4)|
cpu — Central
cpu0 at mainbus?
cpu* at mainbus?
Several processor models have additional features that extend their base functionality, such as power and frequency control or thermal monitoring.
The sysctl(2) hw.cpuspeed returns the current operating frequency of the processor, though on some processors this value may be only an approximation. If possible, speed may be adjusted by altering hw.setperf from 0 to 100, representing percentage of maximum speed. There are several possible implementations for setperf, all transparent to the user. In systems with more than one control capability, they are preferred in the order given:
The presence of extended instruction sets can be determined by the sysctl machdep.
The sysctl(2) hw.sensors.cpu*.temp0 returns the current temperature reported by the processor.
Due to the way in which thermal information is reported on Intel processors, the temperature may be off by exactly +/-15 degrees C.
For multiprocessor kernels with more than one CPU sensor, processors report identical temperatures since the temperature is taken from the processor running the sensors update.
|January 12, 2018||OpenBSD-current|