|LDPD(8)||System Manager's Manual||LDPD(8)|
ldpd — Label
Distribution Protocol daemon
ldpd is the Label Distribution Protocol
(LDP) daemon, which distributes MPLS label mappings between routers.
ldpd can be controlled with the
The options are as follows:
ldpdwill run in the foreground and log to stderr.
E. Rosen, A. Viswanathan, and R. Callon, Multiprotocol Label Switching Architecture, RFC 3031, January 2001.
S. Bryant, G. Swallow, L. Martini, and D. McPherson, Pseudowire Emulation Edge-to-Edge (PWE3) Control Word for Use over an MPLS PSN, RFC 4385, February 2006.
L. Martini, E. Rosen, N. El-Aawar, T. Smith, and G. Heron, Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP), RFC 4447, April 2006.
M. Lasserre and V. Kompella, Virtual Private LAN Service (VPLS) Using Label Distribution Protocol (LDP) Signaling, RFC 4762, January 2007.
L. Andersson, I. Minei, and B. Thomas, LDP Specification, RFC 5036, October 2007.
B. Thomas, K. Raza, S. Aggarwal, R. Aggarwal, and JL. Le Roux, LDP Capabilities, RFC 5561, July 2009.
R. Asati, I. Minei, and B. Thomas, Label Distribution Protocol (LDP) 'Typed Wildcard' Forward Equivalence Class (FEC), RFC 5918, August 2010.
R. Asati, P. Mohapatra, E. Chen, and B. Thomas, Signaling LDP Label Advertisement Completion, RFC 5919, August 2010.
K. Raza, S. Boutros, and C. Pignataro, LDP 'Typed Wildcard' Forwarding Equivalence Class (FEC) for PWid and Generalized PWid FEC Elements, RFC 6667, July 2012.
C. Pignataro and R. Asati, The Generalized TTL Security Mechanism (GTSM) for the Label Distribution Protocol (LDP), RFC 6720, August 2012.
R. Asati, C. Pignataro, K. Raza, V. Manral, and R. Papneja, Updates to LDP for IPv6, RFC 7552, June 2015.
ldpd program first appeared in
|March 4, 2017||OpenBSD-current|