|LDOMCTL(8)||System Manager's Manual (sparc64)||LDOMCTL(8)|
||command [argument ...]|
ldomctlprogram is used to manage logical domains on sun4v systems. It can be used to assign resources to the primary and guest domains, start and stop guest domains from the primary domain, and to display information about domains running on the system.
The following commands are available:
init-systemcommand. The download is aborted if a configuration with the same name already exists.
# ldomctl list factory-default [current]
Create a new configuration based on the defaults:
# mkdir factory-default # cd factory-default # ldomctl dump # cd .. # cp -R factory-default openbsd # cd openbsd
A file describing the desired configuration must be created - see ldom.conf(5).
Generate a set of configuration files and download to non-volatile storage. If a configuration with the same name already exists, it must be removed first:
# ldomctl init-system ldom.conf # cd .. # ldomctl delete openbsd # ldomctl download openbsd # ldomctl list factory-default [current] openbsd [next]
Create a virtual disk image for each guest domain:
# dd if=/dev/zero of=/home/puffy/vdisk0 bs=1m count=8192 # dd if=/dev/zero of=/home/salmah/vdisk0 bs=1m count=8192
The minirootfs install media can be used to boot guest domains:
# cp miniroot56.fs /home/puffy/vdisk1 # cp miniroot56.fs /home/salmah/vdisk1
Enable ldomd(8) by adding the following to /etc/rc.conf.local:
Halt the primary domain and reset the machine from ALOM:
# halt sc> reset -c
The machine will now reset and boot into the new configuration. The primary domain should have less CPUs and memory, since they are now assigned to the guest domains:
# ldomctl status primary running OpenBSD running 1% puffy running OpenBoot Primary Boot Loader 8% salmah running OpenBoot Primary Boot Loader 12%
Configure the vnet(4) interfaces for the guest domains. This example bridges guest domains into the physical network:
# ifconfig vnet0 up # ifconfig vnet1 up # ifconfig bridge0 create # ifconfig bridge0 add em0 add vnet0 add vnet1 up
Access the console of the first domain and boot it:
# cu -l ttyV0 ok boot disk1
ldomctlprogram first appeared in OpenBSD 5.3.
ldomctlprogram was written by Mark Kettenis <firstname.lastname@example.org>.
|July 27, 2019||OpenBSD-current|