OpenBSD manual page server

Manual Page Search Parameters

KTHREAD(9) Kernel Developer's Manual KTHREAD(9)

kthread_create, kthread_exit, kthread_create_deferredkernel threads

#include <sys/kthread.h>

int
kthread_create(void (*func)(void *), void *arg, struct proc **newpp, const char *name);

void
kthread_exit(int ecode);

void
kthread_create_deferred(void (*func)(void *), void *arg);

Kernel threads are system light-weight processes: cloned from process 0 (the swapper), sharing its memory map and limits, but with a copy of its file descriptor table. They don't receive broadcast nor group signals and they can't be swapped.

Any process can call () to create a kernel thread. The new process starts up executing func with argument arg. If newpp is not NULL, it is filled with the address of the new process. name is used to name the process.

A kernel thread will terminate by calling (), with exit code ecode.

Since the system has to be up and running for creating new processes, device drivers that want to create kernel threads early (e.g., at attach time) may use () instead. The system will call back the function func with argument arg when it can create threads, so it is up to func to call kthread_create() at that point.

Upon successful completion, kthread_create() returns 0. Otherwise, the following error values are returned:

[EAGAIN]
The limit on the total number of system processes would be exceeded.

fork1(9)

There is currently no way to use ecode to any sensible purpose from kthread_exit().

November 18, 2013 OpenBSD-current