OpenBSD manual page server

Manual Page Search Parameters

KNOTE(9) Kernel Developer's Manual KNOTE(9)

knote, knote_lockedraise kernel event

#include <sys/param.h>
#include <sys/event.h>

void
knote(struct klist *list, long hint);

void
knote_locked(struct klist *list, long hint);

The () and knote_locked() functions provide a hook into the kqueue kernel event notification mechanism to allow sections of the kernel to raise a kernel event in the form of a ‘knote’, which is a struct knote as defined in <sys/event.h>.

() takes a singly linked list of knotes, along with a hint (which is passed to the appropriate filter routine). knote() then locks and walks the list making calls to the filter routine for each knote. As each knote contains a reference to the data structure that it is attached to, the filter may choose to examine the data structure in deciding whether an event should be reported. The hint is used to pass in additional information, which may not be present in the data structure that the filter examines.

If the filter decides that the event should be returned, it returns a non-zero value and () links the knote onto the tail end of the active list in the corresponding kqueue for the application to retrieve. If the knote is already on the active list, no action is taken, but the call to the filter occurs in order to provide an opportunity for the filter to record the activity.

() is like knote() but assumes that the list is already locked.

() and knote_locked() must not be called from interrupt contexts running at an interrupt priority level higher than ().

kqueue(2)

The knote() functions first appeared in FreeBSD 4.1, and then in OpenBSD 2.9.

The kqueue() system was written by Jonathan Lemon <jlemon@FreeBSD.org>.

February 10, 2023 OpenBSD-current