|IWX(4)||Device Drivers Manual||IWX(4)|
iwx — Intel AX200
IEEE 802.11a/ac/ax/b/g/n wireless network devices
iwx* at pci?
iwx driver provides support for Intel
Wireless AX200 M.2 network adapters.
These are the modes the
iwx driver can
iwx driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA1 and WPA2).
WPA2 is the current encryption standard for wireless networks. It is
strongly recommended that neither WEP nor WPA1 are used as the sole
mechanism to secure wireless communication, due to serious weaknesses. WPA1
is disabled by default and may be enabled using the option
wpa1,wpa2". For standard WPA networks which use
pre-shared keys (PSK), keys are configured using the
wpakey" option. WPA-Enterprise networks
require use of the wpa_supplicant package.
The driver needs one of the following firmware files, which are loaded when an interface is brought up:
These firmware files are not free because Intel refuses to grant distribution rights without contractual obligations. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to download these files on their own.
A prepackaged version of the firmware can be installed using fw_update(1).
The following example scans for available networks:
# ifconfig iwx0 scan
The following hostname.if(5) example configures iwx0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey dhcp
iwx device driver first appeared in
iwx driver does not support any of the
802.11ac and 802.11ax capabilities offered by the adapters. Support for
802.11n 40MHz channels and Tx aggregation is not yet implemented. Additional
work is required in ieee80211(9)
before those features can be supported.
This driver does not support powersave mode.
|February 15, 2020||OpenBSD-current|