|IPW(4)||Device Drivers Manual||IPW(4)|
ipw — Intel
PRO/Wireless 2100 IEEE 802.11b wireless network device
ipw* at pci?
ipw driver provides support for the
Intel PRO/Wireless 2100 Mini PCI network adapter.
These are the modes the
ipw driver can
ipw driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA-PSK and
WPA2-PSK). WPA is the current encryption standard for wireless networks. It
is strongly recommended that WEP not be used as the sole mechanism to secure
wireless communication, due to serious weaknesses in it. The
ipw driver relies on the software 802.11 stack for
both encryption and decryption of data frames.
The driver needs at least version 1.3 of the following firmware files, which are loaded when an interface is brought up:
These firmware files are not free because Intel refuses to grant distribution rights without contractual obligations. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to find these files on their own. The official person to state your views to about this issue is firstname.lastname@example.org.
A prepackaged version of the firmware can be installed using fw_update(1).
The following example scans for available networks:
# ifconfig ipw0 scan
The following hostname.if(5) example configures ipw0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey dhcp
ipw driver first appeared in
ipw driver was written by
This driver does not support powersave mode.
|March 29, 2019||OpenBSD-current|